Latest Inquiries - Data Extraction Software

In Group template, Element Wait Condition not work

Submitted: 3/25/2016
Hi,
In project Pec5001000.rip in attachment (with Pec5001000.csv input), there is a Group template with:
- two form field filled from the csv
- Form Image
- Form Element
and after a Submit Form.

From the second loop, the problem is: when form navigate back, the Form Image need time to be updated, the error is: CAPTCHA image was not found.
Seems that the Form Image inside the group template hasn't a working Element Wait Condition and the project failed.

Can you solve this in my project?

--------------

I tried also to build another project to do the same, wihout Group template. The project is Test2.rip with Denominazione.csv and Provincia for the two fields.
Here the Element wait condition on Form Image work but every loop Provincia field was updated, Denominazione no and remain the same.

--------------

I need one working project for do this, please help me to solve this!

Thanks in advance

Pec5001000.rip
Test2.rip
Denominazione.csv
Provincia.csv
Pec5001000.csv

Replied: 3/30/2016 1:42:26 AM
Your FormSubmit template still had the Navigater Back option checked. I've cleared the option in the attached project.
Pec5001000.rip

Replied: 3/30/2016 8:02:07 AM
Please try the attached project. It uses a Back template with a slight time delay. It works for me.
Pec5001000v.rip

Replied: 4/4/2016 12:07:14 PM
Now it works!
Please can you explain the modify that you have added? I haven't find on file but exist!

Regards
Replied: 3/30/2016 4:19:32 PM
Hi,
I try and check your project but still not work, it's the same error, not work, I need to retry manually to have captcha solve.
On my computer I have tried to add some dalays on many parts of project but it's the same.

Try another time if it's possible, I don't know why but not work for me.

--------------------

If can be useful try to check test2.rip project, its the same at the beginning of topic.
The project Test2.rip with Denominazione.csv and Provincia for the two fields.
Here the Element wait condition on Form Image work but every loop Provincia field was updated, Denominazione no and remain the same.

--------------------

Thanks
Pec5001000.csv
Pec5001000x.rip
image.jpg
Test2.rip
Denominazione.csv
Provincia.csv

Replied: 3/29/2016 9:54:42 AM
I've looked at the Pec5001000 project. In this specific case you can clear the Misc option Navigate back, since the project does not need to navigate back after clicking search. 
Replied: 3/31/2016 5:37:38 AM
Plese try the attached project.
Pec5001000x.rip

Replied: 3/29/2016 10:27:44 AM
I've tried to clear the Misc option Navigate Back on Form template and not work. I also tried to clear the Navigate Back on Group Template and not work.
Please try to check the project.
Regards
Pec5001000.csv
Pec5001000.rip

Replied: 3/30/2016 2:06:50 AM
Hi,
I run the project but there is the same problem (I've also update VVR).
In attachment you can find a screenshot of my problem.

Regards
Pec5001000.csv
Pec5001000v.rip
image.jpg

Replied: 4/5/2016 2:56:39 AM
The project will not wait for wait elements directly after a Back template, so I added an additional Link template inside the Back template.